0
Under review

I have lost my mute option

Dividend Latitude 12 months ago • updated by SA Admin Daniel Hochman 12 months ago 1

My "mute" option went away a few weeks ago. Also, the link to report inappropriate comments also disappeared.

Under review

Try clicking the arrow at the top right of any comment