+3
Started

Unable to RESET PASSWORD...

ForestFromTrees 2 years ago in Website updated by SA Jacob Maltz 1 year ago 4

So I noticed my email address at SeekingAlpha has a typo with it (as I'm logging in with Google+) and wanted to change it. But I'm unable to because my Password isn't be recognized. When clicking on the link sent to us to 'Reset Password', it goes to a page that isn't even operational! (Error 500)

I think I'm in the same position - I login with my Google account so never set a password but that means I can't post comments because it asks for a password I never set.

I now see that this was asked a month ago and still no response :(

I tried the reset and was forced to create a new account.

Started

First of all, what kind of typo do you see in your email ? Is it missing some dots ?  If so it is by design, please ignore it. for more information see here

I will try and reproduce the issue of inability to write a comment without a password from a user created with google plus.