contribution center

  • updated

I click on contribution center / write an article. However, it keeps directing me to the homepage.


Ben, I know you must be checking https in browser window right? I have the same problem with all of alpha doing that to me. Like right now its a security issue that I came back on to answer you back. Somehow they really need to fix this issue. It also says google/sam when I log in. Which is incorrect. Check your website, clear your cookies, check browser or application to make sure its updated then restart application. Its always good to check the credentals of each website you visit. I dont know if that will help your broken linking but if not try finding diffrent source for their security contact and let them know whats going on. Hope that helps you. Thanks for using this platform. Now is the time we all help to fix it and find any backdoors, redirects so I can come here and do amazing things! Good Luck! 


Hi, thanks for your response. Unfortunately, i cleared the cookie and closed my browser. I tried to login and click contribution center / write an article, problem still persists. I used my another laptop and problem still persists.

However, when I login using different seeking alpha account and it worked.