Not a bug

Click on your profile on top right of page, click settings, then change the email address.