0
Under review

Lost Access to Account

Quantrarian 2 years ago in Website updated 2 years ago 9

Hi,


This is a bit of an unusual situation.


I had a seeking alpha account (Username: "BlackHatGuy") that I set up a couple of years ago, set chrome to auto-log-in and never really thought about my email/password again.


Recently, I set up seeking alpha on my mobile. I had to find out what my credentials were, so I used the "recover password" option and cycled through the ~5 emails I've used in the past decade until I found the one that was in your system, guessed the password, and that was fine. Used that to set up on my phone and logged in online.


Except, apparently, the SA account associated with that email is a much older one that I haven't been using. And I now don't know the credentials to log in to my current one.


I've tried "recover password" with every email I've ever used in the past 5 years, with no luck. Somehow, there's no credentials saved in my browser password manager anymore. I'm at a loss for how to recover it. 


I don't really mind losing the comment history, but I *do* really like my username, and I'm intending to start contributing articles to SA, and I would really like to recover it. 


In summary:


There's an account, "BlackHatGuy", that I was using up until recently, but I have lost the login credentials, and it doesn't seem to be associated with any of the emails I can think of, so I'm at a loss for how to regain access to it.


Any help would be much appreciated.

Under review

Hi,


The domain for that username is @luminw...co.uk (redacted) . Does that help?

hmm. No luck. It's possible there was a typo in the original email. 


Could you send a password reset email and see if it gets delivered?

It does. I thought I'd tried that one but I'll go back and try some more. Thank you.

Why stop working?

I have sent a reset password.

Do you have any way of knowing if the delivery failed?

Because I've got nothing on my end.

I only see afer I send the comment it doesn’t get posted