Under review

message and notification bell not working for Chrome browser

Darren McCammon 4 years ago in Website updated by Long Tail Of Finance 2 years ago 18

The message and notification bell is not working for my Chrome browser.  It will show the red symbol with a number indicating you have new comments; however, when you click it, their is no drop-down.  It does work for Chrome on my other laptop which still has the message / notification as the old square symbol.  It also works in Edge.  So its just the new version of yours software and the Chrome browser combination that has the bug.  I have tried updating the browser, updating Java, allowing pop-ups, including Seeking Alpha as a trusted site, closing and reopening the browser, shutting down and starting back up, all to no avail.

Under review


Can you enter: chrome://settings/help and let us know the Chrome version which isn't working for you?


I have the same problem in firefox and chrome. If you close and reopen the window it works. However, each time you open the window the button only loads the first time. Also, when you click the bell in firefox (chrome is ok) it will not take me to the newest comment anymore.

Firefox 57

Chrome 62.0.3202.94


Same problem here. The notification bell works from the home page only.

Version 62.0.3202.94

TradeNvest -- Good observation.  Thanks; at least there's a workaround.

I reported similar  problem yesterday. I have found that if you go to your profile page(scroll all the way back to the top, click on your avatar, click on profile, you can get the drop down that takes you to the next article).  I am using a chrome based little known browser that has not had problems in years and last update was a week ago but the problem started in the last day or 2.  Also, the notification bell/button is not floating like it was...


I've had the same problem; yesterday and today.  Chrome and IE; Android (tablet - full browser mode) and Win 10.  It doesn't float (used to always stay next to the search icon).  Good observation from Tradenvest that it at least works from the home page.

It works from the contributor center as well.


Workaround -- Home page.  Click the bell.  Right click an item in the list and open in new tab.  The list will stay visible while you do this for each article you want to look at.  pitn but not too bad until they can get the thing fixed.

Right clicking makes it so much easier. =)


I've had the same problem.  The bell always used to be visible even when you would scroll to the bottom of the page to read comments and now it disappears.  You have to scroll back to the top of the page to see it, but just like everyone has stated you have to do a work around in order to get it to work.

For me the bell shows, but does not bring up the list when clicked.  However if I switch stocks or reload sometimes it starts working again, just last two days, worked fine before.  However for 2 weeks the personal icon at top has lost "my feed" so can not see articles by people am following.


Can confirm. Software engineer here with web development experience.
The issue seems to only affect some of the pages (e.g. article pages). On the homepage everything works fine.

It looks like the request to fetch the notifications doesn't even happen on chrome.


Today (11/18 Saturday) it's working from the portfolio page but not from the home page.

And where's Fear & Greed Trader's article?  I get the shakes if F&G's weekly article isn't published on time.

Hi everyone,

I have the same version of Chrome reported here by people (62.0.3202.94) but have not been able to successfully replicate this issue. If anyone here is able to participate in a screenshare so that I can have a developer use 'developer tools' to replicate the issue it would be greatly appreciated. Please respond here and we'll figure out timing.

Thanks and apologies for the issues you are all experiencing. 

This issue should now be fixed. Can people please confirm that the notifications are working properly for them?


Working this morning! Thank you. =)

Seems to be fixed for me this morning! Thanks.


I have enabled Notifications on my SA account, and have enabled it on Chrome browser by adding the SA website web address, yet I don't receive any alerts on Chrome. Could SA tech please advise next steps to troubleshoot this? BTW, SA is the only site that Notification alerts is not working for. Thanks.