Your comments

it seems the web site has a new delay that it did not have before.  I have checked my connection speed and it is the same as in the past.  I have also disabled the adblock.  The delay of about one or two seconds continues on the portfolio page, even when just resorting the holdings.

'view headlines' in the middle of a screen adds no value. 

should be a quick and easy fix to remove it.

agreed--  the new box is in the way and is unnecessary.

I love the new features for My Portfolio on the PC.

Some cosmetic changes would make it even better:

- the exchanges do not need 3 decimal places,2 were fine.

- the size of the exchanges line could be a tad larger.

- the exchanges line should be lower, or locked, so it does not disappear when scrolling down.

- the spacing of portfolio lines could be smaller to see more lines on a page.

- also the spacing on the top of the page could be smaller.

- two columns of '% change' are redundant.

Again, the new features are great. Just some fine tuning would help.

I love the new features for My Portfolio on the PC.

Some cosmetic changes would make it even better:

  - the exchanges do not need 3 decimal places,2 were fine.

  - the size of the exchanges line could be a tad larger. 

  - the exchanges line should be lower, or locked, so it does not disappear when scrolling down. 

  - the spacing of portfolio lines could be smaller to see more lines on a page.

  - also the spacing on the top of the page could be smaller.

  - two columns of '% change' are redundant.  

Again, the new features are great.  Just some fine tuning would help.

Fixed--  the page has been stable since yesterday.  No more jumping up or down.

Thanks.

How much patience do we need?  Is there a projected time-frame when the fix will be ready?

This screen jumping gets more irritating with each passing day.

It appears to be working correctly now.  

Thanks for the quick fix.

for example--  the total gain is currently showing a positive gain, but the % gain is showing a negative %.